标签 Gulp 下的文章

这篇文章是尚硅谷前端Gulp教程的学习笔记。

环境搭建

教程使用的Gulp是3.9,而现在Gulp已经升级到了4.0,改动较大,但是并不影响学习。为了避免环境不一致导致的各种坑,可以安装和教程一致的版本。目前,Node.js的LTS版本为v12.16,已经不兼容Gulp 3.9了,如果Node.js版本过新,会报错:

fs.js:35
} = primordials;
    ^

ReferenceError: primordials is not defined

阅读全文